Настройка IPTV Portal PC NG через TP LINK 3600

Мои поделки
Ответить
TechMike
Site Admin
Сообщения: 223
Зарегистрирован: Вт окт 06, 2009 3:37 pm
Контактная информация:

Настройка IPTV Portal PC NG через TP LINK 3600

Сообщение TechMike »

Код: Выделить всё

/etc/init.d/igmpproxy stop

Код: Выделить всё

rm /etc/igmpproxy.conf

Код: Выделить всё

rm /etc/config/igmpproxy

Код: Выделить всё

echo "config igmpproxy
    option quickleave 1
config phyint
    option network local
    option direction upstream
    list altnet 89.20.157.0/24
    list altnet 192.168.1.0/24
    list altnet 212.1.254.0/24
config phyint
    option network lan
    option direction downstream" >/etc/config/igmpproxy

Код: Выделить всё

echo "quickleave

phyint eth0.2 upstream ratelimit 0 threshold 1
	altnet 89.20.157.0/24
	altnet 192.168.1.0/24
	altnet 212.1.254.0/24

phyint br-lan downstream ratelimit 0 threshold 1" > /etc/igmpproxy.conf

Код: Выделить всё

/etc/init.d/igmpproxy enable

Код: Выделить всё

/etc/init.d/igmpproxy start
После этого должно быть так:

Код: Выделить всё

root@OpenWrt:~# ps |grep igmpproxy
 2588 root       812 S    /usr/sbin/igmpproxy /etc/igmpproxy.conf
 5180 root      1500 S    grep igmpproxy
root@OpenWrt:~#

Код: Выделить всё

echo "config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option target 'ACCEPT'
config rule
    option name 'Allow-IPTV-IGMPPROXY'
    option src 'wan'
    option dest 'lan'
    option proto 'udp'
    option target 'ACCEPT'
    option dest_ip '233.49.170.0/24'" >>/etc/config/firewall

Код: Выделить всё

echo "config interface 'local'
        option proto 'dhcp'
        option ifname 'eth0.2'
        option defaultroute '0'
        option peerdns '0'" >> /etc/config/network
в /etc/config/firewall в раздел

Код: Выделить всё

config zone
    option name 'wan'
    option network 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
добавил

Код: Выделить всё

       option network 'wan local'
далее перезапускаем firewall или лучше перезагружаем роутер, и IPTV должно работать.
TechMike
Site Admin
Сообщения: 223
Зарегистрирован: Вт окт 06, 2009 3:37 pm
Контактная информация:

Re: Настройка IPTV Portal PC NG через TP LINK 3600

Сообщение TechMike »

TechMike
Site Admin
Сообщения: 223
Зарегистрирован: Вт окт 06, 2009 3:37 pm
Контактная информация:

Re: Настройка IPTV Portal PC NG через TP LINK 3600

Сообщение TechMike »

/etc/init.d/cron enable
/etc/init.d/cron enable
Ответить